SofiaITC Mission Critical Solutions Pilz PNOZmulti Configurator | SofiaITC

Pilz PNOZmulti Configurator

This post was originally published on this site

1. EXECUTIVE SUMMARY

  • CVSS v3 3.3

  • ATTENTION: Low skill level to exploit
  • Vendor: Pilz GmbH & Co. KG (Pilz)
  • Equipment: PNOZmulti Configurator
  • Vulnerability: Clear-text Storage of Sensitive Information

2. RISK EVALUATION

Successful exploitation of this vulnerability could allow sensitive data to be read from the system.

3. TECHNICAL DETAILS

3.1 AFFECTED PRODUCTS

The following versions of PNOZmulti Configurator, a safety circuit configuration tool, are affected:

  • PNOZmulti Configurator all versions prior to 10.9

The vulnerability within the PNOZmulti Configurator directly impacts the PMI m107 diag HMI device.

3.2 VULNERABILITY OVERVIEW

3.2.1    CLEARTEXT STORAGE OF SENSITIVE INFORMATION CWE-312

An authenticated attacker with local access to the system containing the PNOZmulti Configurator software can view sensitive credential data in clear-text. This sensitive data is applicable to only the PMI m107 diag HMI device. An attacker with access to this sensitive data and physical access to the PMI m107 diag can modify data on the HMI device.

CVE-2018-19009 has been assigned to this vulnerability. A CVSS v3 base score of 3.3 has been calculated; the CVSS vector string is (AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N).

3.3 BACKGROUND

  • CRITICAL INFRASTRUCTURE SECTORS: Multiple
  • COUNTRIES/AREAS DEPLOYED: Worldwide
  • COMPANY HEADQUARTERS LOCATION: Germany

3.4 RESEARCHER

Gjoko Krstikj of Applied Risk reported this vulnerability to NCCIC.

4. MITIGATIONS

Pilz has discontinued the PMI m107 diag HMI device and the function concerned was removed in PNOZmulti Configurator Version 10.9.

Pilz recommends the following mitigations depending on use of the PMI m107 diag HMI device:

Users that do not use the PMI m107 diag:

  • Install Version 10.9 of the PNOZmulti Configurator software and delete the content of the directory C:Program-DataPilzPNOZmulti Configurator v<version>AppDatapmimicroconfig. (Replace <version> with the used version.)

https://www.pilz.com/download/restricted/PNOZmulti_Configurator_10_9_0_3000683A41.zip (Login Required)

Users that still use the PMI m107 diag:

  • Continue to use the old PNOZmulti Configurator software version and secure the PC and the file system against unauthorized access.

For more information, the Pilz security advisory can be viewed at the following link:

https://www.pilz.com/en-GB/support/downloads#currentPage=1&SEARCH=Security%20Advisory&pilz_group_type=download&SORT=dmodified (Login Required)

NCCIC reminds organizations to perform proper impact analysis and risk assessment prior to deploying defensive measures.

NCCIC also provides a section for control systems security recommended practices on the ICS-CERT web page. Several recommended practices are available for reading and download, including Improving Industrial Control Systems Cybersecurity with Defense-in-Depth Strategies.

Additional mitigation guidance and recommended practices are publicly available on the ICS-CERT website in the Technical Information Paper, ICS-TIP-12-146-01B–Targeted Cyber Intrusion Detection and Mitigation Strategies.

Organizations observing any suspected malicious activity should follow their established internal procedures and report their findings to NCCIC for tracking and correlation against other incidents.

NCCIC also recommends that users take the following measures to protect themselves from social engineering attacks:

No known public exploits specifically target this vulnerability. This vulnerability is not exploitable remotely.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.